This is a brief update; there will be a more complete update to follow later.

Basically, there is a huge vulnerability that has been found in one of the core components of many webservers: OpenSSL.

We at PanamaCityPC are aware of the issue, and in the middle of updating the server to eliminate the vulnerability. After that, we will have to take some other actions to secure ourselves further. Statistically speaking, we were probably not hit, since this issue was experienced by probably a majority of the servers across the entire internet; however, there is always a possibility we were breached.

We will update you further as details become known and we have a chance. Our first priority is to fix the issue.